I suggest you ...

Do not automatically queue up a new cloudcast to play when the current one finishes

Please give an option to disable this new autoplay feature, it's very annoying : (

409 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    AnonymousAnonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    50 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • SikosisSikosis commented  ·   ·  Flag as inappropriate

        WTF ... embedded mixes on a page now autoplay other mixes. I had a mix playing at work, then went home for the weekend and it was playing and tweeting for two days !!!!

      • Phil BoothPhil Booth commented  ·   ·  Flag as inappropriate

        +3 from me! Even with the new UI, which alleviates the visual aspect, you still get these really sudden jarring sound/mood changes which snap me right out of the zone when I'm hacking! :)

      • spiderspider commented  ·   ·  Flag as inappropriate

        Also: make sure that the *only* mixcloud window open on your desktop is the one playing the mix. Make sure any other mixcloud window is closed (the homepage, for example). There can be only one mixcloud window running. If the script doesn't work on the first try, then change the 'sleep, 3000' to 'sleep, 5000' - (you can edit this in notepad and then re-save the script).

      • spiderspider commented  ·   ·  Flag as inappropriate

        Be sure to run the script *only* after you have hit the play button in mixcloud, and be sure to close it immediately after it pauses the next mix. Otherwise it will cause a few headaches (worst case scenario, can always just right-click the autohotkey tray icon and select 'exit' to close it).

      • spiderspider commented  ·   ·  Flag as inappropriate

        just in case of confusion, copy and paste everything (in post below) starting with ";HOW TO USE THIS SCRIPT:" all the way down to the last line. This stops MixCloud from playing more than 2 or 3 seconds of the next mix, and allows you time to choose your own mix. If this gets deleted, then we know that they ARE reasing our comments but are ignoring them. That's fine - I'll still get this script out there in all other ways :)

      • spiderspider commented  ·   ·  Flag as inappropriate

        Here is the script. First download autohotkey and install. (www.autohotkey.com). Then run autohotkey. Then copy/paste ALL of the below text into notepad, and save it as mixcloud-stop.ahk Then right click the saved file and select Run Script. Follow the instructions as you see them below (they are included with the script for safe keeping):

        ;HOW TO USE THIS SCRIPT:

        ;-Install autohotkey (www.autohotkey.com) and click the 'download' link. During the install process, it will ask you to install either the 32-bit or 64-bit, depending on which one your operating system is - choose the appropriate one.

        ;-Select the mix you wish to play at MixCloud.com. Once it has started playing, run this script.

        ;-When the mix has finished playing, it will auto-play onto the next mix (as Mixcloud always does), but this script will immediately stop the next mix from playing. This gives you a chance to select another mix for yourself, and not to allow MixCloud to play another one without your permission.

        ;-Once the mix has paused, THE FIRST THING TO DO IS IMMEDIATELY CLOSE THIS SCRIPT (close it from the tray icon - right click on the autohotkey icon and select 'exit').

        ;-Select another mix of your choice. Press play so it begins. Then load this script again and repeat all above steps. It will again prevent MixCloud from auto-playing the next mix any more than a few seconds into it.

        ;-Tested and works with Firefox, but should work with all browsers, so long as the keyboard shortcut to pause a mix is the spacebar.

        #Persistent
        SetTitleMatchMode, 2
        WinGetTitle, TitleLast, Mixcloud
        SetTimer, CheckChanged, 250 ;Check every quarter-second
        return
        SetTitleMatchMode, 2
        CheckChanged:
        WinGetTitle, Title, Mixcloud
        If (Title <> TitleLast)
        {
        Blockinput, on
        Tooltip, MixCloud has opened a new mix without your permission. Attempting to pause...
        Winactivate, Mixcloud
        sleep, 3000
        send, {space}
        Tooltip,
        Blockinput, off
        }
        TitleLast := Title
        return

      • spiderspider commented  ·   ·  Flag as inappropriate

        don't worry... I'm working on a script that will stop this once and for all. It will prevent your browser from automatically changing to a new mix when the current one is finished. MixCloud is ignorant and selfish in this matter, so the only way to combat it is to program a small app to monitor your browser's current page and when it changes, to disallow that change. I'll post it when it's ready...

      • EarlEarl commented  ·   ·  Flag as inappropriate

        These sites that force music into your queue that you're not interested in is driving me nuts. I'm intelligent enough to decide which Cloudcast to queue next.

        After a Cloudcast completed, I was ready to leave a comment. Bam!!! Another Cloudcast I didn't request queues and begins to play. Stop, Mixcloud. Provide the switch necessary to make my listening experience a pleasant one- the one that allows me to turn automatic queueing off. I checked for one in my account settings. Couldn't find one. Thank God for this post.
        A year and one-half later and it's not resolved. Sigh.....

      • CodyCody commented  ·   ·  Flag as inappropriate

        This enforcement is horrendous. Worse yet, I enjoy sharing what I'm listening to on my social sites, but it also shares whatever crappy mix plays next. My friends see such mixes and respond, "hey that's an awful mix you're listening to" and subsequently have lowered interest in my tastes as well as your website, since I have to explain why I'm listening to such dreadful music (because your auto-queue has 0% accuracy when it comes to predicting my tastes). This gives me two options. 1) Stop sharing what I listen to on mixcloud, but endure terrible follow-up mixes. 2) Switch back to soundcloud. I'm leaning toward the latter.

      • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

        I was actually googling a way to remove this when I discovered this thread.

        I actually would not mind this feature if it was useful and could find a similar mix to what I had been listening to and/or introduce me to a new DJ I would like, or something of this nature. Instead I usually get startled by some seemingly random mix coming out of nowhere, not even remotely close to what I like. Panicked, I rush to turn it off. Every time.

        I think it would be very cool to use this as a way to introduce new mixes based on an algorithm of what I have already favorited, for example. Seems like a missed opportunity?

        I love Mixcloud otherwise. Many many great features, all for free. Thank you!

      • Anonymous commented  ·   ·  Flag as inappropriate

        +1. This is very annoying to switch to some random stuff I almost always dislike. Or at least can we adjust some preferences on what to play next (from arts I follow, or similar genre at the very minimum)? I love mixcloud, but this stupid behavior is killing the experience, and worst, I get asked "what do you listen to this crap?" as a result!

      • Matthew DeaconMatthew Deacon commented  ·   ·  Flag as inappropriate

        I don't understand how this is STILL an issue. It's over a year later, Mixcloud, do you not care about your customers? This should really not be a hard "bug" to fix.

      • Anonymous commented  ·   ·  Flag as inappropriate

        please change it... it was so good how it was before... the preview is fantastic, but this auto play... sucks!

      • Anonymous commented  ·   ·  Flag as inappropriate

        i guess everyone said it all. It's really annoying, random, respectless. time to change it, or will look for another system

      ← Previous 1 3

      Feedback and Knowledge Base